mancata attivazione antenna wireless su portatile

Supporto, consigli, HOWto

Moderatore: die_z

mancata attivazione antenna wireless su portatile

Messaggiodi bissomoro il dom ago 26, 2012 9:37 am

Riciao a tutti. Ho convertito con grandi soddisfazioni anche il vecchio notebook HP nx 7300 a Xubuntu (che trovo nettamente più "gestibile" delle recenti versioni di Ubuntu), con l'unico problema che non riesco ad attivare l'antenna wireless; ho anche installato una vecchia card NETGEAR che non capisco se non è riconosciuta o non riesco a configurare. Controllando il sistema trovo: ethernet controller AIGO networks AGN300 902.11 a/b/g TRUE MIMO wirelees card e come subsystem NETGEAR WPNT511 Range Max 240 mbps wireless card Bus adapter; network controller Broadcom corporation BCM 4311 802,11 b/g wlan, e come subsystem HP BCM 4311802.11 b/g wireless controller. Controllando i driver aggiuntivi, trovo installato attivato in uso Broadcom 802.11 Linux STA wireless driverfor use with Broadcom's BCM4311-, BCM4312-, BCM4313-, BCM4321-,BCM4322-, BCM43224-, and BCM43225-, BCM43227- and BCM43228-based hardware. Tentando di configurare la rete wireless non si attiva.
Potete darmi qualche dritta per attivare questa connessione wireless? Grazie in d'ora
bissomoro
 
Messaggi: 8
Iscritto il: gio giu 17, 2010 11:04 pm

Re: mancata attivazione antenna wireless su portatile

Messaggiodi die_z il lun ago 27, 2012 10:49 am

I chip BCM 43xx, se non ricordo male, richiedono un firmware che non è libero e non può essere ridistribuito.

Sempre a memoria, c'è uno strumento per estrarre il firmware necessario e renderlo disponibile al sistema. Dalla mia Debian:
Codice: Seleziona tutto
apt-cache show b43-fwcutter
Package: b43-fwcutter
Version: 1:015-14
...
Description-en: Utility for extracting Broadcom 43xx firmware
fwcutter is a tool which can extract firmware from various source files.
It's written for BCM43xx driver files.
It grabs firmware for BCM43xx from website and install it.
Homepage: http://wireless.kernel.org/en/users/Drivers/b43



A ogni modo, se il problema è il firmware mancante, nei log di sistema (dmesg, /var/log/syslog, ecc.) dovresti trovare un messaggio di errore che riporta appunto l'impossibilità di caricare il firmware richiesto.
Prova a cercare nei log e in caso riporta qui quello che trovi. Puoi usare ad es.:
Codice: Seleziona tutto
dmesg |grep -i 'firmware'
"A sensible man knows you can not please everybody. A wise man knows you can not please anybody." -- anonymous

GPGkey 0x63C38868 -- Linux counter user n° 356433 -- IPv6 certificate -- http://www.no1984.org/
die_z
 
Messaggi: 234
Iscritto il: mer giu 04, 2008 7:50 am
Località: #0421ug @ irc.freenode.net

Re: mancata attivazione antenna wireless su portatile

Messaggiodi bissomoro il mar ago 28, 2012 10:33 am

Ho eseguito quanto suggerito, ottenendo come risposta:

[ 0.109132] [Firmware Bug]: ACPI: No _BQC method, cannot determine initial brightness
[ 24.117714] [Firmware Bug]: ACPI: No _BQC method, cannot determine initial brightness
[ 24.117828] [Firmware Bug]: _BCQ is used instead of _BQC

Ho anche eseguito delle ricerche per tentare di far riconoscere la scheda Netgear, ma al momento non ho trovato nulla per quel particolare modello, pazienza. Fortunatamente il problema non si è presentato con il netbook, che uso quotidianamente, dove ho installato sempre Xubuntu. Comunque grazie della disponibilità e competenza dimostrate.
bissomoro
 
Messaggi: 8
Iscritto il: gio giu 17, 2010 11:04 pm

Re: mancata attivazione antenna wireless su portatile

Messaggiodi die_z il mar ago 28, 2012 3:21 pm

bissomoro ha scritto:Ho eseguito quanto suggerito, ottenendo come risposta:

[ 0.109132] [Firmware Bug]: ACPI: No _BQC method, cannot determine initial brightness
[ 24.117714] [Firmware Bug]: ACPI: No _BQC method, cannot determine initial brightness
[ 24.117828] [Firmware Bug]: _BCQ is used instead of _BQC

In effetti non sembra lamentarsi della mancanza di firmware.. si potrebbe approfondire ma da remoto non è facile.
Una BCM43xx l'ho avuta e ha sempre funzionato, funziona ancora se accendo l'arnese. Se vuoi posso riesumarlo e dirti che hardware wireless ho di preciso e cosa uso per farlo funzionare.

Ho anche eseguito delle ricerche per tentare di far riconoscere la scheda Netgear, ma al momento non ho trovato nulla per quel particolare modello, pazienza. Fortunatamente il problema non si è presentato con il netbook, che uso quotidianamente, dove ho installato sempre Xubuntu. Comunque grazie della disponibilità e competenza dimostrate.

Meglio trattare una scheda alla volta. Con più di una contemporaneamente si rischia di confondere moduli e firmware.
"A sensible man knows you can not please everybody. A wise man knows you can not please anybody." -- anonymous

GPGkey 0x63C38868 -- Linux counter user n° 356433 -- IPv6 certificate -- http://www.no1984.org/
die_z
 
Messaggi: 234
Iscritto il: mer giu 04, 2008 7:50 am
Località: #0421ug @ irc.freenode.net

Re: mancata attivazione antenna wireless su portatile

Messaggiodi bissomoro il gio ago 30, 2012 8:13 am

Comunico una cosa per me misteriosa ma che può essere interessante: stavo provando e settando l'ultima versione di Puppy Linux in italiano su chiavetta, e Puppy è riuscito ad attivarmi la connessione wifi :mrgreen: Non ho risolto il problema con Xubuntu, ma in caso di necessità.... Difatti questo post lo ho inviato usando Puppy con connessione wireless.
bissomoro
 
Messaggi: 8
Iscritto il: gio giu 17, 2010 11:04 pm


Torna a Software&Co.

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron