Firefox e problemi video

Supporto, consigli, HOWto

Moderatore: die_z

Firefox e problemi video

Messaggiodi vittorino il lun lug 05, 2010 5:21 pm

Ho recentemente scaricato la versione 3.6 di Firefox. Da quel momernto non posso più vedere alcun filmato. Che fare?
vittorino
 
Messaggi: 50
Iscritto il: gio giu 19, 2008 6:30 pm

Re: Firefox e problemi video

Messaggiodi zetsu il lun lug 05, 2010 8:35 pm

E' (stato) un problema anche di debian, dovrebbe bastare seguire gli aggiornamenti del sistema. Comunque domani ribecco un mio amico che ha avuto lo stesso problema, e mi faccio dire come ha risolto.

Non dovrebbe essere un'errore di firefox, ma del plugin flashplayer... Per saperlo prova a vedere qualche filmato con un'altro brovser (dovrebbe esserci epiphani ?).

EDIT:
Ho parlato col mio amico...
Un problema pare essere l'ipv6, prova a disabilitarlo con:
Codice: Seleziona tutto
sudo ifconfig <scheda_di_rete> del <indirizzo_ipv6>

Ovviamente usando la tua scheda di rete e il tuo ipv6, per conoscerli:
Codice: Seleziona tutto
sudo ifconfig

dovrebbe darti come output:
Codice: Seleziona tutto
eth0      Link encap:Ethernet  HWaddr 00:23:8b:0c:40:2b 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:30 Base address:0xc000

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:146 errors:0 dropped:0 overruns:0 frame:0
          TX packets:146 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:9300 (9.0 KiB)  TX bytes:9300 (9.0 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:23:4d:aa:f1:17 
          inet addr:192.168.1.5  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::223:4dff:feaa:f117/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3954 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4017 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2951016 (2.8 MiB)  TX bytes:789110 (770.6 KiB)

In questo caso sono connesso tramite la scheda wifi, quindi <scheda_di_rete> è wlan0 e <indirizzo_ipv6> è fe80::223:4dff:feaa:f117/64
Quindi:
Codice: Seleziona tutto
sudo ifconfig wlan0 del fe80::223:4dff:feaa:f117/64
Linux counter: 486118 macchine: 397489 397490 397491
IPv6 certificato newbie

[...] l'illuminismo al servizio del presente si trasforma nell'inganno totale delle masse.
T. W. Adorno
zetsu
 
Messaggi: 158
Iscritto il: gio giu 05, 2008 1:58 pm
Località: Portogruaro

Re: Firefox e problemi video

Messaggiodi die_z il mar lug 06, 2010 6:14 pm

Questo è uno dei motivi per cui secondo me stabile significa anche vecchio.
Iceweasel e ogni altro browser in Debian stable (lenny in questo momento) funzionano come sempre e, suppongo, anche i vari browser delle distribuzioni "stabili" (tipo le varie Enterprise di Red Hat e Novell).
Ubuntu se ho ben capito ha introdotto anche nella recentissima 10.04 il nuovo Firefox, probabilmente sminchiando un sacco di utenti, non lo so e non indago.. certo è che sarà carina ma certo non stable.

In Debian unstable (sid) amd64 (ricordiamoci che flash è una stronzata che esiste solo nel mondo x86), dato che Adobe non si cura nemmeno di fornire un port per x86_64 a me funziona con il pacchetto flashplayer-mozilla ma non mi sono mai informato sull'argomento. So solo che la versione 10.0.x di flash è stata taggata come portatrice di bachi e pure pesanti, pertanto è uscita la versione 10.1.x, però solo per i386 (32-bit) e anche l'unico port alpha per amd64 (64-bit) è stato rimosso da Apple.. ancora tante grazie. I pochi messaggi che ho letto nelle mailing list (gli altri li ho tutti ignorati) parlano di persone che hanno fatto ricordo a diversi workaround, chi flash a 32bit anche su sistemi a 64bit con lib32 ed emulazioni varie, chi con gnash, chi prelevanto il vecchio flash da reposiroty che ancora ce l'hanno (ad es. marillat per debian-multimedia), chi invocando elementali del fuoco in direzione silicon vall... lasciamo perdere questa soluzione che è meglio.
I casini mi pare inizino con Firefox 3.6.4, fino alla 3.6.3 mi pare funzionasse ancora tutto. Il cambiamento potrebbe essere dovuto all'attivazione di una nuova funzionalità: isolamento dei plugin, tra l'altro funzionante per ora solo con... flash ;)

<rant>
La vera soluzione è ovviamente non usare flash, ma per quanto lo si dica c'è sempre qualcuno pronto a rispondere "ma lo usano tutti!" e poi mettersi a piangere. Se volete buttarvi dal ponte come tutti gli altri fate pure, io per la tua valvola preferisco continuare a scassare i maroni per HTML5, webM, vp8 e compagnia bella, a breve anche sui vostri schermi, sì, anche se fino a oggi avete solo rotto le scatole con 'sto c***o di flash.
</rant>


bye_z!
"A sensible man knows you can not please everybody. A wise man knows you can not please anybody." -- anonymous

GPGkey 0x63C38868 -- Linux counter user n° 356433 -- IPv6 certificate -- http://www.no1984.org/
die_z
 
Messaggi: 234
Iscritto il: mer giu 04, 2008 7:50 am
Località: #0421ug @ irc.freenode.net

Re: Firefox e problemi video

Messaggiodi zetsu il mer lug 07, 2010 9:38 am

Ho solo riportato una delle 2 soluzioni che mi ha detto il mio amico che usa ubuntu... io sulla debian ho forzato l'uso del pacchetto bacato...

die_z ha scritto:...port alpha per amd64 (64-bit) è stato rimosso da Apple
Apple?
Linux counter: 486118 macchine: 397489 397490 397491
IPv6 certificato newbie

[...] l'illuminismo al servizio del presente si trasforma nell'inganno totale delle masse.
T. W. Adorno
zetsu
 
Messaggi: 158
Iscritto il: gio giu 05, 2008 1:58 pm
Località: Portogruaro

Re: Firefox e problemi video

Messaggiodi die_z il mer lug 07, 2010 10:19 am

zetsu ha scritto:
die_z ha scritto:...port alpha per amd64 (64-bit) è stato rimosso da Apple
Apple?

lol :lol: Adobe
"A sensible man knows you can not please everybody. A wise man knows you can not please anybody." -- anonymous

GPGkey 0x63C38868 -- Linux counter user n° 356433 -- IPv6 certificate -- http://www.no1984.org/
die_z
 
Messaggi: 234
Iscritto il: mer giu 04, 2008 7:50 am
Località: #0421ug @ irc.freenode.net

Re: Firefox e problemi video

Messaggiodi zetsu il mer lug 14, 2010 3:41 pm

Se hai una versione di ubuntu a 64 bit, prova a dare una letta qui
Linux counter: 486118 macchine: 397489 397490 397491
IPv6 certificato newbie

[...] l'illuminismo al servizio del presente si trasforma nell'inganno totale delle masse.
T. W. Adorno
zetsu
 
Messaggi: 158
Iscritto il: gio giu 05, 2008 1:58 pm
Località: Portogruaro

Re: Firefox e problemi video

Messaggiodi vittorino il sab lug 17, 2010 3:58 pm

Cari voi che mi rispondete, siccome non riesco a vedere alcunchè dopo aver caricato l'ultima versione di firefox ho deciso di tornare indietro e di riprendere la Ubuntu 8.04 ma alle disgrazie non c'è mai fine. Ho preparato un CD di avvio riesco a vederlo a video tra le 5 opzioni che vi sono scelgo Installa Ubuntu e il risultato è il seguente messaggio in alto: [139.476286] ..MP-BIOS bug: 8254 timer not connected to IO-APIC; [139.656236] Kernel panic -not syncing:IO-APIC + timer doesn't work! try using the 'noapic' kernel parameter. In basso appaiono le seguenti scritte: Kernel alive - Kernel direct mapping tables up to 100000000 @ 8000-d000. A questo punto mi sono fermato ho levato il CD mi sono riletto le pagine dedicate all'installazione di Ubuntu dal libro di R. Blum Linux per NEGATI ma non sono previste difficoltà particolari per l'installazione del S.O. ed io sono di nuovo al punto di partenza. Ho in macchina Ubuntu 10.04 Lucid Lynx che dopo aver upgradato Firefox non mi fa vedere alcun filmato. Dove sbaglio? Attendo fiducioso.
vittorino
 
Messaggi: 50
Iscritto il: gio giu 19, 2008 6:30 pm

Re: Firefox e problemi video

Messaggiodi die_z il sab lug 17, 2010 6:12 pm

vittorino ha scritto:ho deciso di tornare indietro e di riprendere la Ubuntu 8.04

Non condivido molto la scelta.. ci sono 2 anni e 5 release di ubuntu tra aprile 2008 e oggi.. come mai proprio 8.04?

try using the 'noapic' kernel parameter.

Questo significa avviare la macchina con il suddetto parametro (o anche noacpi, per stare sul sicuro) aggiunto alla riga di comando di linux. Per fare una cosa simile dovresti modificare la riga di grub, non è una cosa particolarmente difficoltosa ma concordo sul fatto che non dovrebbe essere necessario arrivarci.
Come alternativa potresti disabilitare acpi dal bios. Evidentemente hai hardware che non è il massimo della compatibilità.

Ho in macchina Ubuntu 10.04 Lucid Lynx che dopo aver upgradato Firefox non mi fa vedere alcun filmato. Dove sbaglio? Attendo fiducioso.

Direi che non sbagli tu.
Hi aggiornato di recente? Secondo me ti basterà non fare nulla e attendere nuovi aggiornamenti che correggono il problema.
Se nel frattempo hai modificato qualcosa nella configurazione del sistema o dell'utente, rimetti tutto a posto prima di aggiornare e poi installa tutte le ultime versioni disponibili. Con buona probabilità ti ritroverai con una macchina di nuovo funzionante.

Su col morale, non è poi una cosa così grave ;)


bye_z!
"A sensible man knows you can not please everybody. A wise man knows you can not please anybody." -- anonymous

GPGkey 0x63C38868 -- Linux counter user n° 356433 -- IPv6 certificate -- http://www.no1984.org/
die_z
 
Messaggi: 234
Iscritto il: mer giu 04, 2008 7:50 am
Località: #0421ug @ irc.freenode.net

Re: Firefox e problemi video

Messaggiodi vittorino il dom lug 18, 2010 4:38 pm

Ho pensato a Ubuntu 8.04 perchè il manuale cui ho fatto riferimento porta esempi su esso. Oggi comunque ho scaricato Opera e con questo browser funziona tutto, vedo i filmati e sento le musiche. Mi pare però che sia più lento di Firefox nel caricare le pagine.
vittorino
 
Messaggi: 50
Iscritto il: gio giu 19, 2008 6:30 pm


Torna a Software&Co.

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti

cron